Joomla! is een open source Content Management System, gebruikt om websites te bouwen en te beheren. Zo is deze website opgezet met Joomla!. Joomla! loopt op de PHP pre-processor. PHP is er in vele soorten, voor diverse operating systems. Naast  PHP heeft u een Web server nodig. Joomla! is geoptimaliseerd voor de Apache Web server, maar werkt ook in andere Web servers zoals Microsoft IIS. Het heeft dan aanvullende configuratie eisen voor PHP en MySQL. Joomla! is gebaseerd op een database, Hiervoor kunt u momenteel alleen MySQL gebruiken.

Veel mensen weten uit ervaring dat het niet altijd makkelijk is om een Apache Web server te installeren en het wordt nog lastiger als  MySQL, PHP en Perl te installeren. XAMPP, WAMP, en MAMP zijn eenvoudig te installeren  distributies bevattende Apache, MySQL, PHP en Perl voor de  Windows, Mac OSX en Linux operating systems. Deze distributies zijn alleen voor lokaal gebruik.
De Minimum vereisten zijn:

  • Apache 1.x of2.x
  • PHP 4.3 of hoger
  • MySQL 3.23 of hoger

Voor de Laatste minimum vereisten bezoek de Joomla! website en Joomla Forums